Issue with all products
Incident Report for Tink
Postmortem

Introduction 

On 20th January between 06:02 and 06:11 CET Tink experienced a technical issue which impacted Payments and Account Check Products for the European market. During the time of the incident, end-users and customers were experiencing issues with initiating payments and carrying out Account Checks. 

Root Cause Analysis 

After a thorough investigation, it was found out that Tink’s service used to connect to banks (via use of eIDAS certificates) experienced a brief connectivity issue, leading to the product degradation. 

Remediation 

The recovery process worked as designed and the issue self-healed. 

Follow-up actions 

To prevent similar issues in the future Tink will be implementing the following actions: 

  1. Continue to improve platform resiliency by upgrading selected internal services 
  2. Carry out a table-top exercise to simulate this scenario to investigate potential ways to shorten the self-recovery time. 
Posted Jan 22, 2025 - 18:48 CET

Resolved
We experienced a drop in Tink Link success rate between 06:02 and 06:08 CET.

Due to this issue, all of our products were briefly unavailable or showed temporary performance issues.

The availability has since returned to normal. We apologize for the inconvenience.
Posted Jan 20, 2025 - 06:59 CET
This incident affected: Payments, Account Check, Transactions, Income Check, Risk Insights, Expense Check, and Money Manager.