Issue with several products
Incident Report for Tink
Resolved
We experienced an issue with creating credentials between 19:56 and 20:03 on 2024-05-08.

A significant drop in success rates for most flows occurred during this time.

Performance has since returned to normal. We apologize for the inconvenience.
Posted May 08, 2024 - 20:12 CEST
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, and Expense Check.