Issue affecting Payments

Incident Report for Tink

Resolved

Between 10:54 CET and 11:23 CET Tink has encountered a technical issue that impacted Payments products for multiple markets.
The underlying root cause that caused the incident was resolved. We apologize for any problems this issue may have caused.
Posted Apr 17, 2025 - 11:46 CEST
This incident affected: Payments.