Nordea Open Banking Bulk payments - Tink Link error screen

Incident Report for Tink

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 20, 2026 - 09:12 CET

Investigating

We are currently looking into an issue with Nordea bulk payments. The initiation for the SE market has been failing for about 3 hours.
Posted Mar 19, 2026 - 22:16 CET
This incident affected: Payments.