Issue with Settlements

Incident Report for Tink

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 17:22 CEST

Identified

We have identified and are currently investigating an issue with our provider which is affecting both outbound and inbound SEPA payments, which may result in delays.
Posted Sep 26, 2025 - 15:30 CEST
This incident affected: Payments.