Issue with multiple products
Incident Report for Tink
Postmortem

Introduction

On February 9, between 9:56 AM CET and 10:05 AM CET, Tink experienced a technical issue affecting Tink's Payment Initiation, Account Check, Business Account Check, Risk Insights, Income Check and Expense Check products in all markets. During this period the Tink platform failed to handle incoming traffic properly, which resulted in lower availability of the mentioned products.

Root Cause Analysis

During a short period with high load there was an issue in the internal platform service handling traffic routing, which caused an outage of the affected products.

Remediation

The load configuration of the affected service was immediately adjusted which resolved the issue.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Increasing test capabilities to cover the specific scenario
Posted Feb 13, 2024 - 09:02 CET

Resolved
Since 10:01 CEST situation has returned to normal. We are very sorry for any disturbances this issue has caused.
Posted Feb 08, 2024 - 10:18 CET
Monitoring
Tink has experienced a brief technical issue at 9:55 CEST that affected multiple products. This issue has been identified and at this point is already resolved. We are monitoring the situation.
Posted Feb 08, 2024 - 10:11 CET
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, and Money Manager.