Issue with Payment Initiation service
Incident Report for Tink
Postmortem

Introduction

On 25th of November between 9:07 and 9:35 (CET), Tink experienced intermittent technical issues that impacted our Payments products for selected Customers, for a total of 20 minutes, during which end-users were unable to initiate payments.

Root Cause Analysis

Payments were impacted due to one of the components within the Payments service experiencing an undesired behavior that led to a cascading effect on other dependent components and eventually preventing payments from initializing.

Remediation

The faulty component in question was disabled and payments traffic was switched to an alternative flow, which allowed payments to be initiated properly.

Follow-up actions

Tink is planning to implement the following remediation actions:

  1. Optimization of the faulty service
  2. Improved monitoring and alerting for the platform
  3. More hardware resources configured for the faulting services
  4. Implementation of automatic restarts when similar faults are detected
Posted Nov 28, 2022 - 12:33 CET

Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 10:31 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2022 - 09:39 CET
Investigating
We are currently investigating an issue with Payment Initiation service starting at 9:07, all markets are affected.
Posted Nov 25, 2022 - 09:30 CET
This incident affected: Payment Initiation.