Issue with Payments service
Incident Report for Tink
Postmortem

Introduction

On 2022-06-27, Tink experienced a degradation of service between 15:40 to 15:45 where our internal database component affected the Payment Initiation service. As a result, 30% of users were affected.

We know how important it is to our customers that we provide a highly available and reliable service and we sincerely apologize for the disturbances this incident caused.

Root Cause Analysis

The root cause of this was due to an error during the addition of a new database node. This caused failure in payments for approximately 5 minutes.

Remediation

Engineering teams were alerted within minutes, and the issue was resolved at 15.45.

Follow-up actions

As a consequence of this incident we will focus on the following actions to prevent similar scenarios from occurring again: 

  • Improving the error detecting for faster alerting
  • Upgrading database components to prevent this specific issue to happen again
Posted Jul 07, 2022 - 09:22 CEST

Resolved
There was a partial outage affecting Payment initiation during 15:40 and 15:45. Aproximately 30 % of users were affected.
Posted Jun 27, 2022 - 03:30 CEST