Account exclusion functionality is currently not working as expected

Incident Report for Tink

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 11, 2026 - 16:19 CEST

Investigating

We are currently investigating an issue with the account exclusion functionality, as accounts are not being excluded as intended. Further updates will be provided as soon as possible.
Posted May 11, 2026 - 15:32 CEST
This incident affected: Transactions.