Issue affecting all products
Incident Report for Tink
Postmortem

Introduction 

On March 21st 2023 between 11:58 and 12:16 CET Tink experienced a technical issue which impacted Payments product for Belgian, Finnish, German, Italian, Dutch, Spanish and Swedish markets. During the time of the incident, end-users were experiencing issues with initiating payments.

Root Cause Analysis

After the thorough investigation, it was found out that certain certificate renewal operations were not optimized properly which led to service timeouts and certificate versions mismatch.

Remediation

Once the issue was identified, the certificate rotation was aborted and the previous working certificate version had been brought back. 

Follow-up actions

 To prevent similar issues in the future Tink will be implementing the following actions:

  1. The verification and improvement of the existing renewal process
  2. The enhancement of the automated validation process
  3. The improvement of the monitoring metrics.
Posted Mar 28, 2023 - 11:33 CEST

Resolved
This incident has been resolved. This issue affected all customers using Tink's licence.
Posted Mar 21, 2023 - 12:29 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 12:23 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2023 - 12:16 CET
This incident affected: Payments, Account Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, and Money Manager.