Issue affecting several Tink products

Incident Report for Tink

Postmortem

Introduction 

On 2026-07-07 between 15:26 and 15:51 CEST, Tink experienced a technical issue which impacted API availability for some of our customers. During the incident, end-users experienced issues with accessing affected Tink services. 

Root Cause Analysis 

After a thorough investigation, the event which triggered the temporary API availability issue was identified and successfully addressed. 

Remediation 

Once the issue was identified, Tink restored service availability and implemented additional protective measures to improve resilience against similar events. 

Follow-up Actions 

To prevent similar issues in the future, Tink will be implementing the following actions: 

  1. Strengthen protective controls across relevant production environments. 
  2. Improve monitoring and response procedures for high-impact availability events. 
  3. Review and enhance service resilience to reduce the impact of similar incidents.
Posted Jul 09, 2026 - 16:32 CEST

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jul 08, 2026 - 15:37 CEST

Monitoring

Service is currently recovering and we are actively monitoring the situation.
Posted Jul 07, 2026 - 15:54 CEST

Investigating

We are currently investigating an issue that is affecting several Tink products.

See details for the full list of affected products.
Posted Jul 07, 2026 - 15:39 CEST
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and TinkLink demo (demo.tink.com).