Issue affecting several Tink products
Incident Report for Tink
Postmortem

Introduction

On January 16, a technical issue affected Tink's Payment Initiation, Account Check, Business Account Check, Risk Insights, Transactions, Income Check and Expense Check products for all markets. There were two periods of time, from 10:10 to 10:39 CET, and from 14:05 to 14:36 CET, when the Tink platform failed to handle incoming traffic properly, which resulted in lower availability of the products mentioned.

Root Cause Analysis

The issue was caused by a degradation of our load balancing infrastructure during high traffic periods following a configuration change impacting Tink’s auto-scaling mechanism.

Remediation

Once the configuration issue was identified, the impacting change was rolled back.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. We will be adding extra monitoring for this component to capture the specific error conditions, improving MTTR (Mean Time to Recovery)
  2. Specific Infrastructure changes will be subjected to additional load testing validation in a testing environment,  prior to deployment into production.
Posted Jan 19, 2024 - 09:45 CET

Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Jan 16, 2024 - 10:47 CET
Investigating
We are currently investigating an issue that is affecting several Tink products.

See details for the full list of affected products.
Posted Jan 16, 2024 - 10:24 CET
This incident affected: Payments, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, and Expense Check.