Issue with several products - Major Outage
Incident Report for Tink
Postmortem

Introduction

On 1st of June 2023 between 05:49 CEST and 06:24 CEST Tink’s services experienced a degraded performance affecting multiple products (AIS, Account Check, Transactions, Income Check, Risk insights, Expense Check, Connector API, Payments). The degradation resulted in a major outage during the time of the incident. 

We know how important it is to our customers that we provide a highly available and reliable service and we sincerely apologize for the disturbances this incident caused.

Root Cause Analysis

The incident was caused by a failure to scale one of the key services in the Tink Platform to accommodate request patterns during a planned increase in traffic. This caused degraded performance in the transaction processing. 

Remediation

At 06:24 CEST the load had been reduced and performance went back to normal across all Tink products. 

Follow-up actions

As a consequence of this incident we will focus on the following actions to prevent similar scenarios from occurring again: 

  • Increase available memory for the affected service
  • Increase observability to more easily be able to pinpoint built up load in parts of the service 
  • Long term improvements planned to the transaction processing architecture
Posted Jun 06, 2023 - 10:41 CEST

Resolved
We experienced a major outage today between 05:49 CEST and 6:23 CEST.

This issue affected refreshes on the following products:

Payment Initiation
Account Check
Business Account Check
Transactions
Business Transactions
Income Check
Expense Check
Risk Insights

Performance has since returned to normal. We apologize for the inconvenience.
Posted Jun 01, 2023 - 06:23 CEST
This incident affected: Payments, Account Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, and Expense Check.