Issue with Income Check and Risk Insights
Incident Report for Tink
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Nov 29, 2023 - 10:23 CET
Investigating
We are currently investigating an issue with Income Check and Risk Insights affecting all markets.
Posted Nov 29, 2023 - 10:02 CET
This incident affected: Income Check and Risk Insights.