Issue with Payments
Incident Report for Tink
Resolved
We experienced a temporary network issue between 08:44 AM and 08:59 AM CEST.

During that time, the availability of Payments product was affected.

The performance has since returned to normal. We apologize for the inconvenience.
Posted Jul 26, 2024 - 09:17 CEST
This incident affected: Payments.