Issue with Payment Initiation

Incident Report for Tink

Resolved

Service is back to normal.
Posted Sep 25, 2026 - 07:57 CEST

Update

We are monitoring post recovery.
Posted Sep 25, 2026 - 07:43 CEST

Investigating

We are currently investigating an issue with Payment Initiation.
Posted Sep 25, 2026 - 07:14 CEST
This incident affected: Payments.