Issue with Expense check
Incident Report for Tink
Resolved
We experienced Issue with Expense check between 16:02 and 16:23.

Performance has since returned to normal. We apologise for the inconvenience.
Posted Mar 09, 2023 - 16:42 CET
This incident affected: Expense Check.