Issue with Settlements

Incident Report for Tink

Resolved

We can confirm that the previously identified issue affecting inbound and outbound SEPA payments has now been resolved. Payments are processing as expected.

We apologise for the inconvenience caused and thank you for your patience.
Posted May 22, 2026 - 09:39 CEST

Monitoring

We continue to monitor an issue affecting both outbound and inbound SEPA payments. While some payments are processing, we cannot yet confirm full service restoration. We are actively investigating and will provide a further update as soon as possible. We apologise for the inconvenience.
Posted May 21, 2026 - 15:29 CEST

Investigating

We have identified and are currently investigating an issue with our provider which is affecting both outbound and inbound SEPA payments, which may result in delays.
Posted May 19, 2026 - 11:53 CEST
This incident affected: Settlement accounts.