Issue with multiple products
Incident Report for Tink
Postmortem

Introduction

On 5th June between 14:21 and 14:29 CEST Tink experienced a technical issue which impacted the availability of all products across all markets. During the time of the incident, customers would have been unable to access Tink’s APIs.

Root Cause Analysis

After a thorough investigation, it was found that a planned change to perform annual SSL certificate renewal was incorrectly implemented. As part of the import process the certificate chain was inadvertently altered causing a validation error upon the certificates. This impacted access to all services.   

Remediation

Once the issue was identified, the change was quickly rolled back, restoring the availability of our Products back to normal.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Increase level of automation and validation for certificate renewal
  2. Increase gradual rollout capabilities for certificate renewal
Posted Jun 12, 2024 - 13:43 CEST

Resolved
Tink has experienced a brief issue for a portion of customers, during a scheduled certificate rotation between 14:21 CEST and 14:29 CEST.
During the timeframe multiple products were unavailable.
Performance has since returned to normal. We apologize for the inconvenience.
Posted Jun 05, 2024 - 15:08 CEST
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.