Issue with Payments
Incident Report for Tink
Resolved
Tink has experienced a brief technical issue between 14:36 and 14:41 CET that affected Payment Initiation product. This issue has been identified and at this point is already resolved. We are monitoring the situation.
Posted Feb 15, 2024 - 15:28 CET
This incident affected: Payments.