Issue with Bulk Payments

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jun 16, 2026 - 13:32 CEST

Identified

The issue has been identified and we are currently working on a solution.
Posted Jun 16, 2026 - 12:15 CEST
This incident affected: Payments.