Issue with multiple Tink products

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jan 21, 2026 - 10:47 CET

Investigating

We’re currently experiencing degraded performance affecting multiple products since 10:01 CET. Some users may encounter issues with availability.
Posted Jan 21, 2026 - 10:33 CET
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.