Issue with Expense Check
Incident Report for Tink
Resolved
We experienced availability issues for Expense Check product between 14:15 CEST and 15:20 CEST.

During that time, Expense Check product was unavailable and generation of reports was not possible.

The availability has since returned to normal. We apologize for the inconvenience.
Posted Sep 13, 2024 - 17:00 CEST
This incident affected: Expense Check.