Issue with multiple products

Incident Report for Tink

Postmortem

Introduction 

On 20th November between 11:50 and 12:30 CET Tink experienced a technical issue which impacted AIS and PIS products in all markets. During the time of the incident, end-users were experiencing issues with initiating payments, fetching transactions, performing account and balance checks, and generating risk reports. 

Root Cause Analysis 

After a thorough investigation, it was found that the issue was triggered by a change which resulted in an impact on the service's stability which in turn degraded the performance of our AIS and PIS offerings. 

Remediation 

Once the issue was identified, the change was immediately rolled back. This brought the affected service back to normal operation. 

Follow-up actions 

To prevent similar issues in the future, Tink will be implementing the following actions: 

  1. Enhance the code review and internal testing process for the service in scope of the change. 
  2. Exposing changes to a smaller share of production traffic and gradually increasing the volume, allowing for a swifter rollback before issues become highly impacting.
Posted Nov 26, 2025 - 15:37 CET

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Nov 20, 2025 - 16:37 CET

Monitoring

Service is currently recovering and we are actively monitoring the situation.
Posted Nov 20, 2025 - 12:34 CET

Investigating

We are currently investigating an issue with multiple products affecting all markets.
Posted Nov 20, 2025 - 12:09 CET
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, and Expense Check.