Issue with multiple Tink products

Incident Report for Tink

Postmortem

Introduction

On 24th November between 15:06 and 15:30 CET Tink experienced a technical issue which impacted all products in all European markets. During the time of the incident, end-users were experiencing issues with initiating payments, fetching transactions, performing account and balance checks, generating risk reports.

Root Cause Analysis

After a thorough investigation, it was found that the issue was caused by an attempt to resume a failed backup job on our main production database. Initiating a command to verify data integrity caused a lock on the database.

Remediation

Once the issue was identified, the process which was causing the lock was terminated.

Follow-up actions

To prevent similar issues in the future, Tink will be implementing the following actions:

  1. We are strengthening our internal processes so that any resource-intensive commands meant to be run on production databases should go through internal review with full risk assessment and run on replicas and/or non-production environments first
Posted Nov 26, 2025 - 16:51 CET

Resolved

We experienced a technical issue between 15:06 CET and 15:24 CET.

During this time users had issues with availability of Tink products.

Status has since returned to normal. We apologise for the inconvenience.
Posted Nov 24, 2025 - 15:29 CET
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.