Issue with all Tink products

Incident Report for Tink

Postmortem

Introduction 

On two separate occasions – on 14th April between 13:04 and 13:12 CEST and on 15th April between 04:00 and 04:11 CEST, Tink experienced a technical issue which impacted all AIS and PIS products for all European markets. During the time of the incident, end-users were experiencing issues with successfully completing Tink Link flows affecting Payment Initiation, Account Check and generating Risk reports.

Root Cause Analysis 

After a thorough investigation, it was found out that the issue was caused by a brief network issue in our cluster causing a temporary disruption in the provisioning of services responsible for the operation of our products. 

Remediation 

Once the issue was identified, we isolated the fault and ensured the network stability was fully restored. 

Follow-up actions 

To prevent similar issues in the future Tink will be implementing the following actions: 

  1. Permanently correct the node configuration of our virtualization cluster
  2. Carry out additional testing to identify resiliency deficiencies
Posted Apr 16, 2025 - 17:24 CEST

Resolved

We experienced a technical issue between 13:04 CEST and 13:12 CEST.

The issue caused a brief unavailability of all Tink products

Performance has since returned to normal. We apologize for the inconvenience.
Posted Apr 14, 2025 - 13:33 CEST
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.