Issue with multiple services
Incident Report for Tink
Postmortem

Introduction

On 29th September, Tink experienced a partial outage between 17:45 and 18:50 (CEST) affecting the availability of the majority of our services and products. During this time most end-users were unable to authenticate, aggregate accounts or initiate payments.

Root Cause Analysis

An auto-scaling issue in one of our services interrupted the on-demand refresh operation. This led to the saturation of the server resources and as a result credentials stopped being updated.

Remediation

Affected services were restarted at 18:50 (CEST) after which authentication flow components returned to stability.

Follow-up actions

As a consequence of this incident we will focus on the following actions over the coming weeks to prevent a similar scenario from occurring again:

  1. New alerts to be put in place to react faster to auto-scaling issues.
  2. We will perform additional load and stress tests to ensure we are able to handle  increased traffic on our services.
Posted Sep 30, 2022 - 18:54 CEST

Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 19:01 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 29, 2022 - 18:51 CEST
Investigating
We are currently investigating an issue with multiple services.
Posted Sep 29, 2022 - 18:10 CEST
This incident affected: Payment Initiation, Account Check, Transactions, Business Account Check, Business Transactions, Income Check, and Risk Insights.