Issue with webhooks
Incident Report for Tink
Postmortem

Introduction

On January 14 2025, between 10:17 and 12:33 CET, Tink experienced a technical issue which impacted Webhooks v2 delivery. During the time of the incident, Webhook events were not sent, causing different issues depending on how Webhook V2 events have been integrated in customer platforms.

The following Webhook events were not sent during the time of the incident.

  • account-booked-transactions:modified
  • account-transactions:deleted
  • account:updated
  • account-transactions:modified
  • payment:updated
  • refresh:finished

Webhook v1 events were not affected during the incident.

Root Cause Analysis

After a thorough investigation, it was found that a configuration change caused the validation of Webhook subscriptions to fail and Webhook events not being sent.

Remediation

Once the issue was identified, the change was reverted and the issue resolved.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Strengthening our regression test suite to cover this specific configuration and to increase our general test coverage.
  2. Strengthening our monitoring by adding more granular alerts per Webhook configuration segment.
Posted Jan 16, 2025 - 17:07 CET

Resolved
Between 10:17 and 12:33 CET Tink has experienced an issue that impacted our ability to send v2 events.

We have pinpointed the root cause of the issue and resolved it.

We are sorry any issues this may have caused.
Posted Jan 14, 2025 - 13:07 CET
This incident affected: Payments and Transactions.