Issue with Payments and Account Information

Incident Report for Tink

Resolved

We experienced degraded performance on February 27, 2025, between 21:05 and 21:15 CET.

During this period some account information refreshes and payments may have failed.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Feb 28, 2025 - 08:36 CET
This incident affected: Payments, Account Check, Balance Check, Transactions, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, and Data Enrichment.