Disruptions for the Payments service on the German market

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted May 22, 2026 - 00:47 CEST

Investigating

We are currently investigating an issue with payments in German market.
Posted May 21, 2026 - 23:52 CEST
This incident affected: Payments.