Issue with Bulk Payments

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Mar 25, 2026 - 11:04 CET

Investigating

We are currently investigating an issue with Bulk Payments in Sweden.
Posted Mar 25, 2026 - 10:15 CET
This incident affected: Payments.