Issue with Payments

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jun 03, 2026 - 10:31 CEST

Monitoring

Service is currently recovering and we are actively monitoring the situation.
Posted Jun 02, 2026 - 12:25 CEST

Investigating

We are currently investigating an issue with Payment Initiation.
Posted Jun 02, 2026 - 11:45 CEST
This incident affected: Payments.