Issue with Payments
Incident Report for Tink
Postmortem

Introduction

On Dec 6th, between 13:06 and 13:12 CET Tink experienced a technical issue which impacted Payment Initiation, Risk Insights, Income Check and Expense Check products for all markets. During the time of the incident, end-users were experiencing disturbances in the availability of the services.

Root Cause Analysis

There was a brief interruption in connectivity between the application services and one of our security services. During the incident window application services were unable to perform encryption & decryption services. This caused interruptions in the connection between Tink and banks.

Remediation

Once the issue was identified, the system automatically initiated self-healing and restored service. 

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Error handling to manage timeouts added
Posted Dec 18, 2023 - 16:17 CET

Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Dec 06, 2023 - 13:38 CET
Investigating
We are currently investigating an issue with Payments for all our markets.
Posted Dec 06, 2023 - 13:28 CET
This incident affected: Payments.