Degraded performance of Tink Link affecting all products

Incident Report for Tink

Postmortem

Introduction 

On March 6th 2025 between 10:50 and 11:16 CET Tink experienced a technical issue which impacted all Tink products in all markets. During the time of the incident, end-users were experiencing issues with payments and account refreshes, with slower responses and timeouts. 

Root Cause Analysis 

After a thorough investigation, it was found out that the issue had been caused by an automation to delete expired sessions executing too many requests in parallel which resulted in timeouts/failures to acquire connections for incoming requests 

 

Remediation 

The issue was resolved automatically when all accumulated deletion requests were processed. 

 

Follow-up actions 

To prevent similar issues in the future Tink will be implementing the following actions: 

  1. Improve alerting to detect case when delete jobs is queuing up 

    1. Improve robustness of session clean-ups to batch deletion of jobs
Posted Mar 11, 2025 - 15:35 CET

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Mar 06, 2025 - 11:34 CET

Investigating

We are currently investigating an issue with Tink Link affecting all products on all markets.
Posted Mar 06, 2025 - 11:18 CET
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.