Issue with Payments

Incident Report for Tink

Resolved

We experienced a technical issue between 24 and 30 July.

During this time, some payments were missing debtor account details in markets where this information is expected to be delivered asynchronously via payment status updates.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Jul 31, 2025 - 11:05 CEST
This incident affected: Payments.