Degraded performance of Tink Link

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Oct 13, 2025 - 18:13 CEST

Investigating

We are currently investigating an issue with Tink Link that is affecting all products in Sweden.

Users may experience degraded performance in the desktop journey, specifically with BankID connections across Swedish banks. We are working to identify the root cause and will provide updates as soon as we have more information.
Posted Oct 13, 2025 - 14:39 CEST
This incident affected: Payments, Settlement accounts, Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, and Business Manager.