Issue with Payment Initiation

Incident Report for Tink

Resolved

We experienced a technical issue between 04:10 CEST and 04:17 CEST.

During the timeframe the Payment Initiation was not available.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Apr 08, 2025 - 04:47 CEST
This incident affected: Payments.