Increased latency across Tink services
Incident Report for Tink
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted May 23, 2023 - 16:04 CEST
Identified
The issue has been found and we are currently working on a solution.
Posted May 23, 2023 - 14:13 CEST
This incident affected: Account Check, Balance Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Expense Check, Money Manager, Data Enrichment, Business Manager, and Other.