Issue with Payments
Incident Report for Tink
Resolved
We experienced an issue with Payments between 12:50 and 12:53 CET on 2022-03-14.

For a few minutes, performance for Payments was degraded.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Mar 14, 2023 - 16:19 CET
This incident affected: Payments.