Redirect with embedded TinkLink does not work
Incident Report for Tink
Postmortem

Impact

Redirect back to client’s mobile app (iOS and Android) not working in Tink Link.

Time of issue in production : 3d 2h 30m
Time to resolution for incident : 5m

Cause of the incident

An update to the code on 2021-02-08 introduced a bug which broke redirect back to the client app native apps after a user was done authenticating in the bank apps.

Solution

Update to the redirect path used for when redirecting back from the bank app to the native client app.

Actions

Adding new tests to extend the test coverage for communication between the bank  and client native apps, focusing on checks for redirects.

Timeline

Time Action
2021-02-08 12:26 A change in the code was introduced that broke redirect back to the client's native app after authentication in the bank app was done.
2021-02-10  A change in the code was introduced that broke redirect back to the client's native app after authentication in the bank app was done.
2021-02-11 13:42 Incident is declared
2021-02-11 13:45 Update is deployed to production that resolves the incident.
Posted Feb 17, 2021 - 15:57 CET

Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 14:00 CET
Investigating
If you are using TinkLink embedded, the redirect bank from the bank app to your does not work at the moment. We are investigating the issue.
Posted Feb 11, 2021 - 13:50 CET
This incident affected: Aggregation services and Payments services.