Issue with Payments
Incident Report for Tink
Postmortem

Introduction

On May 29th 2024 between 03:11 AM and 03:40 CEST Tink experienced a technical issue which impacted Payments in all markets. During the time of the incident, end-users were experiencing issues while performing Strong Customer Authentication for Payments.

Root Cause Analysis

After a thorough investigation, it was found that congestion of requests, in the service establishing connections to banks, caused latency in the platform. The congestion was caused by an abnormal traffic pattern in combination with an inefficient retry mechanism. The queued requests caused increased latency impacting Strong Customer Authentication for Payments.

Remediation

Once the issue was identified, the queue handling for connecting to banks was reset, and requests causing increased latencies aborted.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Adjust the timeout and retry mechanism in the platform to prevent congestion
  2. Improve logging in the retry mechanism
Posted May 31, 2024 - 13:47 CEST

Resolved
We experienced a degraded performance of Payments product between 03:11AM and 03:40AM.

During that period, our customers may have experienced latency when attempting to initiate payments.

The performance has since returned to normal. We apologize for the inconvenience.
Posted May 29, 2024 - 05:11 CEST
This incident affected: Payments.