Partial outage AIS for Transaction Customers
Incident Report for Tink
Resolved
This incident is now resolved.
Posted Jul 28, 2021 - 17:03 CEST
Investigating
We are currently investigating.
Posted Jul 28, 2021 - 16:20 CEST