Issue with Settlement accounts

Incident Report for Tink

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Mar 05, 2025 - 19:00 CET

Investigating

We are currently experiencing a delay to outbound Euro payments being processed.
Posted Mar 05, 2025 - 16:30 CET
This incident affected: Settlement accounts.