Issue affecting multiple products
Incident Report for Tink
Postmortem

Introduction

On November 16 between 12:46 and 12:57 CET Tink experienced a technical issue which impacted Payment Initiation, Account Check, Business Account Check, Risk Insights, Income Check and Expense Check products for all markets using PSD2 connections. During the time of the incident, end-users were not able to use the products.

Root Cause Analysis

In an effort to decrease error rates coming from Bank APIs, Tink performed a change in its HTTP header structure for outgoing traffic (connections between Tink and Banks). While being tested on pre-production environments, the new header structure turned out to be incompatible with a large number of PSD2 connections and led to SSL connections failures that caused the outage.

Remediation

Once the issue was identified, the change was reverted and the services were back to normal after 11 minutes interruption.

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Adding extra layer of test coverage in the critical domain of establishing SSL connections
Posted Nov 28, 2023 - 12:55 CET

Resolved
Recovery is now complete. Incident is now resolved. We are sorry for any inconvenience this issue has caused.
Posted Nov 16, 2023 - 13:27 CET
Monitoring
We have resolved the underlying issue and are now in recovery phase.
Posted Nov 16, 2023 - 13:00 CET
Identified
We are aware of issues with multiple Tink products. We are actively troubleshooting these issues.
Posted Nov 16, 2023 - 12:47 CET
This incident affected: Payments, Account Check, and Transactions.