Issue affecting several Tink products
Incident Report for Tink
Postmortem

Introduction

On 2024-09-11 between 14:07 CEST and 14:13 CEST Tink experienced a technical issue, which impacted the following products: Payments, Money Manager, Account Check, Transactions, Income Check, Risk Insights and Expense Check. During the time of the incident end-users were experiencing issues with availability of the mentioned products.

Root Cause Analysis

After a thorough investigation, it was discovered that a scaling issue in our underlying infrastructure led to internal services becoming unavailable. During this period customers would have experienced timeouts or errors when iterating with the services. 

Remediation

The issue self healed as Auto-Scaling adjusted to meet demand and load was distributed across the cluster

Follow-up actions

To prevent similar issues in the future Tink will be implementing the following actions:

  1. Review service and node resource limits within the infrastructure to avoid resource contention in future 
  2. Add additional metrics to identify and alert on areas of resource contention.
Posted Sep 18, 2024 - 08:57 CEST

Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Sep 11, 2024 - 14:25 CEST
Investigating
We are currently investigating an issue that is affecting several Tink products.

See details for the full list of affected products.
Posted Sep 11, 2024 - 13:56 CEST
This incident affected: Payments, Account Check, Transactions, Income Check, Risk Insights, Expense Check, and Money Manager.