Issue affecting several Tink products

Incident Report for Tink

Postmortem

Introduction 

On August 11th, between 11:30 CEST and 12:15 CEST, Tink experienced a technical issue that impacted Payments and Account Information products across multiple markets. During the incident, some end-users encountered issues with the availability of certain Tink products. 

Root Cause Analysis 

After a thorough investigation, it was identified that there was an error in one of the third-party libraries used to read feature flags, which led to an unrecoverable runtime error in a critical service. This, in turn, caused degradation in the availability of our products. 

 

Remediation 

Once the issue was identified, all affected instances were restarted. To mitigate the issue, a full restart was required, which contributed to the extended downtime for some products. 

 

Follow-up actions 

To prevent similar issues in the future Tink will be implementing the following actions: 

  1. Downgrade all critical services to a stable version until the third-party library has been fixed.
Posted Aug 12, 2025 - 20:13 CEST

Resolved

After some troubleshooting we were able to pinpoint the root cause of the issue and apply a fix. Incident is now resolved. We apologise for any issue this incident has caused.
Posted Aug 11, 2025 - 12:20 CEST

Investigating

We are currently investigating an issue that is affecting several Tink products.

See details for the full list of affected products.
Posted Aug 11, 2025 - 11:58 CEST
This incident affected: Payments, Account Check, Transactions, Income Check, and Risk Insights.