Issue with Income Check
Incident Report for Tink
Resolved
We have experienced an outage with Income Check between 09:39 and 09:46 CEST today.

The issue has been resolved and performance has since returned to normal. We apologize for the inconvenience.
Posted Sep 09, 2022 - 10:45 CEST
This incident affected: Income Check.