Issue with Payment service
Incident Report for Tink
Postmortem

Introduction

On 18th November, Tink experienced a partial outage between 16:11 and 16:50 (CET) affecting the availability of the Payments products. During this time end-users were unable to initiate payments.

Root Cause Analysis

Increased traffic resulted in network issues with one of the Payment Initiation components, which caused a major product performance  degradation.

Remediation

Affected services were restarted at 16:50 (CST) services were  stabilized and returned to a healthy state.

Follow-up actions

As a consequence of this incident we are focusing on the following actions:

  1. Optimisation of the faulty service
  2. Improved monitoring and alerting for the platform
  3. More hardware resources configured for the faulting services
  4. Implementation of automatic restarts when similar faults are detected
Posted Nov 23, 2022 - 08:39 CET

Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 18:12 CET
Investigating
We are currently investigating an issue with Payment service .
Posted Nov 18, 2022 - 16:23 CET
This incident affected: Payment Initiation.