Issue affecting several Tink products

Incident Report for Tink

Postmortem

Introduction 

On 16th July between 09:54 and 10:56 CEST Tink experienced a technical issue which impacted Tink Console, Tink Link, Payment Initiation Services, Account Information Services, and selected risk products for all European markets. During the time of the incident, end-users were experiencing issues with starting or completing authentication, consent, account-information, and payment-initiation journeys, and were unable to log in to Tink Console to manage their integrations with Tink platform. 

Root Cause Analysis 

After a thorough investigation, it was found out that an external infrastructure dependency provided by Tink’s cloud provider used for routing customer-facing traffic malfunctioned, which led to interruption of Tink Link-based user journeys and temporary unavailability of Tink Console access for some customers. 

Remediation 

Once the issue was identified, Tink routed affected traffic through an alternative configuration and restored the impacted services to normal operation. 

Follow-up actions 

To prevent similar issues in the future, Tink will be implementing the following actions: 

  1. Improve monitoring and alerting for critical external infrastructure dependencies. 
  2. Document and validate recovery procedures for routing around similar failures. 
  3. Run additional training for faster identification and handling of comparable infrastructure-related issues.
Posted Jul 22, 2026 - 15:26 CEST

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jul 20, 2026 - 14:47 CEST

Monitoring

Service is currently recovering and we are actively monitoring the situation.
Posted Jul 16, 2026 - 11:11 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 10:55 CEST

Identified

The issue has been identified and we are currently working on a solution.
Posted Jul 16, 2026 - 10:42 CEST

Investigating

We are currently investigating an issue that is affecting several Tink products.

See details for the full list of affected products.
Posted Jul 16, 2026 - 10:17 CEST
This incident affected: Payments, Account Check, Income Check, Risk Insights, Expense Check, and TinkLink demo (demo.tink.com).