Issue with multiple service
Incident Report for Tink
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Jul 01, 2022 - 15:10 CEST
Investigating
We are currently investigating an issue that is affecting several Tink services.

See details for the full list of affected services.
Posted Jul 01, 2022 - 15:05 CEST
This incident affected: Payments.